CADSUPER FXU Ver.4.00
   
  FXU本体関連
    機能強化項目
    1. ファイルダイアログ
     
パラメータ変換を行うファイル種類(拡張子)を選択した場合、ファイルダイアログ上でパラメータ選択ができるようになりました。
他形式ファイルのあるフォルダをフォルダリンクとして設定する場合、デフォルトのパラメータファイルを設定できるようになりました。
ファイル検索機能で、検索情報と検索結果をひとつのダイアログに統合しました。
指定フォルダ以下に存在するファイルも検索対象にできる設定を用意しました。
検索結果ダイアログから、ダブルクリックで指定図面を開くようにしました。
    2. 認識機能
     
矩形認識の時、囲む方向(左右)で全体/部分認識を切替える設定を用意しました。
グループ認識ダイアログを単純要素マスクの設定まで表示することで、利用しやすく改善しました。
グループ認識マスクを記憶/呼び出しできるようにしました。
グループ認識マスクを簡単に初期状態に戻せるようにしました。
既存要素を選択して、簡単に同一属性の認識マスクを作成できるようにしました。
前回のグループ認識要素を簡単に再認識できるようにしました。
対象要素が欠落していない必要があります。
ハッチング同士、ハッチングと外周要素との交点を「認識対象とする/しない」を設定できる機能を用意しました(ユーザプロパティ-全般2)。
    3. レイヤ機能
     
レイヤセット単位で分割表示できる機能をを用意しました。
※「寸法線」「文字」の特殊レイヤセットは表示されません。
カレントレイヤセット内のレイヤのみを分割表示できる機能を用意しました。
カレントレイヤセット以外のレイヤセットを、[参照]/[表示]/[休眠]化する機能を用意しました。
(レイヤ状態設定)レイヤセット単位での[縮尺]および、[線種][線幅][色][レイヤ状態][出力]の設定を変更できる機能を用意しました。
(ユーザプロパティ設定)レイヤパネル上への縮尺表示の有無、表示位置を設定できる機能を用意しました。
(レイヤパネル)カレント(作図対象)のレイヤセット、レイヤの先頭に[*]マークをつけて、カレントが判別できるようにしました。
(レイヤパネル)投影/グループのレイヤセット単位、用紙内レイヤのレイヤ毎に縮尺を表示するようにしました。
レイヤセット間の[移動]/[複写]機能を、新たに用意しました。
※複写先、移動先に元と同じ名称のレイヤが存在することが利用必須条件となります。
基準レイヤ以外のレイヤ縮尺を一括で変更する機能を、新たに用意しました。
コマンド定義より[ツール]内の[レイヤ縮尺一括変更]コマンドを割付けてご利用ください。
    4. スタイル機能
     
図面が異なっても特定のスタイルで作図編集できるように、スタイルを固定化する機能を用意しました。
図面にスタイルを保持し、図面毎のスタイルを利用できる機能を用意しました。
寸法線作図を固定属性で利用できるように設定を追加しました。
スタイルパネル上で利用中のスタイルセットが判別できるようになりました。
固定スタイルで利用する場合、図面内属性とスタイルが一致しない場合が発生しますが、この時、「属性置換機能」か「スタイル設定」を連続で起動して設定変更を容易にできるようにしました。
    5. コマンドモード
     
コマンドモードをクリック時、コンボボックスのようにリストから選択できる機能を用意しました。
コマンドモードをアイコンのみ表示する設定を用意しました。(システムローカル設定−全般:コマンド制御)
    6. コンソールパネル
     
文字入力などの場合に、知らない間に入力制限文字数を越えないように、制限を設けました。
座標入力機能の初期状態として、前回利用の状態を維持するようにしました。
数値/文字入力が必須ではない場合、[ESC]キーを打鍵することで、フローティング状態のコンソールパネルを閉じるようにしました。
コンソールパネルが小さく、入力フィールドに全桁が表示できない場合、入力フィールド上にマウスを移動することで、入力フィールドにある値をチップ表示するようにしました。
入力フィールドの履歴表示状態で、特定の履歴を削除できる機能を用意しました。
    7. 寸法コマンド
     
長さ寸法作図時、第一計測点として線分を選択した場合、その線分の角度を寸法角度に利用するようにしました(作図方向自動の場合)。
長さ寸法ドラッグ時に[Shift]キーを打鍵することで、表示中の寸法タイプ(水平/垂直/平行)で固定/解除する機能を搭載しました(作図方向自動の場合)。
長さ寸法ドラッグ時、わずかな角度の寸法と水平/垂直寸法のいずれかが分かるように作図形状のタイプをマウスカーソル横に表示するようにしました。
[半自動]寸法線で作図時、長さ寸法ドラッグ時、指定したタイミングのみ【φ】、【 () 】が設置できる設定機能を用意しました。
部品属性を引出す場合、配置確定前に確認ダイアログを表示し、条件などを変更できるようにしました。
データム記号を寸法補助線に配置できるようにしました。
寸法記号の作図サイズを寸法文字サイズに依存することなく個別に設定できる機能を用意しました。
片矢倍寸法:中心線を指定することで、計測点から中心線までの倍の長さを表示する片矢寸法線作図機能を、新たに用意しました。
[寸法]−[長さ]−[倍片矢]
単独角度寸法:描画点として指定する位置を挟む(180°未満)形状に作図する角度寸法線機能を、新たに用意しました。
[寸法]−[角度]−[単独]
コメントなし引出し線:コメント入力のない引出し線(寸法属性)作図機能を、新たに用意しました。
[寸法]−[コメント無し引出し線]※コマンド定義で割付けてご利用ください。
    8. コマンドカスタム起動
     
特定のコマンドモード設定で起動する別コマンドとして登録できる機能を用意しました。
コマンド定義でカスタムコマンドとして登録した機能を、ツールバー、キー、ポップアップメニューに割付けできるようにしました。
FXの機能に近い状態にしたコマンドをデフォルトで用意していますので、コマンド定義で割付けて利用できます。
    9. FX図面I/O
     
FX−FXU変換に利用できるパラメータ作成・編集機能を用意しました。
パラメータ利用のFX図面読込み、保存機能を用意しました。
    10. [部品]−[機械要素]コマンド
     
新たに[六角穴付きボタンボルト]コマンドを用意しました。
新たに[皿ボルト]コマンドを用意しました。
(六角ボルト)座金部分を別部品として描画する設定を用意しました。これにより、座金を材料取りする事が可能です。
(六角穴付きボルト)座金部分を別部品として描画する設定を用意しました。これにより、座金を材料取りする事が可能です。
(六角穴付きボルト)平面図配置時、反転して描画する設定を用意しました。
(六角ナット)座金部分を別部品として描画する設定を用意しました。これにより、座金を材料取りする事が可能です。
(ちょうボルト)座金部分を別部品として描画する設定を用意しました。これにより、座金を材料取りする事が可能です。
(ちょうナット)座金部分を別部品として描画する設定を用意しました。これにより、座金を材料取りする事が可能です。
(小ねじ)座金の描画を用意しました。
(タップ)貫通設定を行った場合、「サイズ」属性を任意に変更できる機能を用意しました。
(平行ピン)正面図配置時の基準位置に、左右の中点を追加しました。
(テーパピン)正面図配置時の基準位置に、左右の中点を追加しました。
(ダウエルピン)正面図配置時の基準位置に、左右の中点を追加しました。
(穴パターン)配置時の部品名にデータの「名称」を使用する事ができる機能を用意しました。
(穴パターン)属性名について、データ毎に保持する異なった値を使用する設定を用意しました。
([設定]−[部品]−[機械要素設定])細い隠れ線の設定を用意しました。
各コマンド内で「隠れ線」をチェックした場合、従来は同一の線種で描画されていましたが、今後は「外形線」→「隠れ線」、「細線」→「細い隠れ線」で描画されるようになります。
    11. [編集]−[分解]−[線分分解]コマンド(新設)
      指定された要素(円弧、楕円弧、曲線)に対して、入力される誤差範囲で線分分解します。
コマンドモードによる動作切替で、分解後の形状として、「集合要素(線分の集合)」とするか「近似曲線」に変換するか選択することが出来ます。
対象要素は、グルーピング(枠囲み)できるようになっていますので、複数の曲線を一括して変換することが出来ます。
また、極端な角度で折れている曲線については、折れている位置で別曲線として変換することが出来ます。
    12. [計測]−[体積]コマンド(新設)
      ループで指定された範囲に対して、指定軸での回転形状、及び高さ入力による押出し形状の体積を算出する機能を、新たに用意しました。
    13. FX機能の移植
     
【MC図面読込み】【MC図面保存】の機能をFXUに移植しました。
[ファイル]−[MC図面管理]− [MC図面読込み]
    [MC図面保存]
【自由曲線作成】【自由曲線修正】の機能をFXUに移植しました。
[作図]− [自由曲線作成]
  [編集]−[曲線の頂点編集]− [自由曲線修正]
【アイソメ作図】の機能をFXUに移植しました。
[ツール]−[アイソメ図]− [正面図指定]
  [平面図指定]
  [側面図指定]
  [3面投影]
  [母線作図]
  [軸線削除]
  [領域変更]
  [投影条件表示]
【新しいウインドウを開く】機能をFXと同様のオペレーションで行う機能にしました。
Ver.3.X以前の【新しいウインドウを開く】はコマンド定義で割付け利用できます。
 
    機能改善項目
    1. [ファイル]−[システムローカル設定]
      (表示/出力)縮小印刷時に、印刷範囲から図枠等がはみ出ないようにする範囲補正をしない設定を用意しました。
補正しない場合、作図用紙対出力用紙のサイズ比になります。
    2. [ファイル]−[上書き保存]コマンド
      上書き保存コマンド終了時に、FXのように確認音を鳴らすようにしました。
    3. [ファイル]−[名前をつけて保存]コマンド
      EasyDrawデータへの上書き保存をできるようにしました。
    4. [ファイル]−[プリンタ出力]−[全領域]/[範囲]コマンド
      要素色⇒線幅の設定利用できる機能を用意しました。
    5. [作図]−[線]−[垂線]コマンド
      指定した基準線上の点から、垂線を作図できる機能を追加しました。
    6. [作図]−[円]/[円弧]−[中心点]/[3要素]コマンド
      円/円弧作図時に中心線以外に、中心点を作図する機能(コマンドモード)を追加しました。
    7. [作図]−[円]−[中心点]コマンド
      初回入力した半径を2回目以降、「Enter」入力するだけで採用するように改修しました。
※コンソールパネルがオートハイド、フローティングで常時表示ではない場合、1回目の「Enter」でコンソールパネルが表示され、もう一度「Enter」入力することで値が採用されます。
    8. [編集]−[複写]−[平行]/[平回転]/[拡縮]コマンド
      要素を図面間複写する場合に、複写先基準レイヤの縮尺を利用する設定を用意しました。
    9. [編集]−[移動]/[複写]−[レイヤ間]コマンド
      移動(複写)基準点を指定した場合に、対象要素をドラッグを表示するようにしました。
    10. [編集]−[要素属性]−[要素変更]コマンド
      要素変更機能で、文字の線幅も変更されるようにしました。
※ベクトル文字、ベクトル表示の場合のみ有効となります。
    11. [編集]−[変形]コマンド
      「X,Y」の変位を入力することで、変形を行う機能を用意しました。
    12. [寸法]−[引出し]−[部品属性]コマンド
      属性引出しを行った際、配置前に配置文字列を変更できるようにしました。
    13. [文字]−[定型]コマンド
     
ベクトルフォント用に縦書きを行う設定で、「縦書き」を選択した場合、強制的にフォントをベクトルに変更する設定を用意しました。
図面属性キーワードを配置する際、「文字列に変換してから配置する(図面属性の変更が反映されない)」設定を用意しました。
※なお、Ver4未満ではこの設定がONになっている状態で動作する仕様となっていましたので、初期状態ではこの機能をONに設定しています
「作成日(長い形式)」用に、新たに「%_CL%」キーワードを用意しました。
「%CL%」には、計測変数CL(円弧長)が割り当てられているため、Ver4未満では「作成日(長い形式)」を配置する事ができませんでした。
    14. [文字]−[記号]コマンド
      中線が1本の記号について、配置される文字列(上下ともに)と中線との空間間隔を設定できる機能を用意しました。
    15. [文字]−[文字属性]コマンド
      文字基準点を変更した場合に、文字表示位置を移動しないで基準点だけ変更する機能を用意しました。
    16. [文字]−[上下均等]コマンド
      均等処理を行う際に基準とする位置を、文字列の上部・中央・下部からも選択できる機能を用意しました。
以前は、各文字列の垂直基準点を元に均等処理を行っていました。
    17. [設定]−[ユーザプロパティ設定]コマンド
     
作図中に[ユーザプロパティ設定]コマンドを起動すると、《現在利用中の状態で》ユーザプロパティが表示されますが、図面を開いた当初の「初期状態」に戻せる【初期化】ボタンを用意しました。
(マウス)マウスドラッグによる「パンニング」「ズーミング」を利用しない設定を用意しました。
    18. [ツール]−[プロコマンド]コマンド
     
(円座標)部品名だけでなく、属性の違いによっても表を分ける設定を用意しました。
(円座標)X軸・Y軸の方向を反転させる設定を用意しました。
(円座標)表の横幅を任意に指定する設定を用意しました。
(引出2)引出線を描かない設定を用意しました。
(引出2)座標値を上下に並べて描く設定を用意しました。
    19. [ツール]−[計算]−[電卓]コマンド
      べき乗演算子(^)を追加しました。
    20. ナビゲーション+窓表示
      確認窓表示がある状態でナビゲーションを利用した場合、窓が開いても、選択した座標を最初に確認するようにしました。
    21. 属性変更ダイアログのビジュアル化
     
[編集]-[要素属性]-[要素変更]で利用される変更ダイアログで線種、線幅、色をイメージ表示もあわせて行うようにしました。
[編集]-[要素属性]-[ハッチング形状]で利用される変更ダイアログで線種、線幅、色をイメージ表示もあわせて行うようにしました。
[文字]-[文字属性]で利用される変更ダイアログで線種、線幅、色をイメージ表示もあわせて行うようにしました。
 
    機能改修項目
    1. [ファイル]−[システムローカル設定]コマンド
     
(全般)FX図面読込み時の線種名称 に文字を登録していても、削除されなかった現象を改修しました。
(出力初期設定)プリンタ情報を保持する場合、図面の方向補正を行わないように改修しました。
    2. [ファイル]−[開く]コマンド
      FX図面を読み込んだ場合に、線幅とプロッタペン番号が一致しなくなる現象を改修しました。
    3. [ファイル]−[名前をつけて保存]コマンド
     
読み込んだFX図面を別名称で登録した場合、利用履歴(ファイルメニューの下方)に登録されるように改修しました。
累進寸法を他形式に出力する場合、プロポーショナルフォントで作図されている寸法値の文字位置が寸法線と重なる現象を改修しました。
(FX形式保存)レイヤの表示状態が一部正常に反映されなかった現象を改修しました。
(JX形式保存)レイヤの表示状態が一部正常に反映されなかった現象を改修しました。
ファイル名に「.(ピリオド)」を複数含む場合に拡張子を変更すると、最初の「.(ピリオド)」までがファイル名として判定されていた現象を、【最後の「.(ピリオド)」までがファイル名】と判定するように改修しました。
    4. [編集]−[トリム]−[角丸め]コマンド
      線分選択後に丸め距離を入力しても、ハングアップしないように改修しました。
    5. [編集]−[複写]−[平行]コマンド
     
大量の要素を[矩形の切断]で認識しても、正常に他図面に複写できるように改修しました。
塗潰し要素を他図面に複写しようとすると失敗する現象を改修しました。
要素を移動するためドラッグ状態の場合に、レイヤモードを切替るとドラッグ表示が消える現象を改修しました。
    6. [編集]−[変形]コマンド
      寸法付きの形状を寸法方向に距離入力で変形しようとした時に、変形できない場合があったのを改修しました。
    7. [寸法]−[角度]−[基準]コマンド
      基準レイヤと異なる縮尺のレイヤに角度基準寸法線を作図すると、対象要素からの引き上げ距離が異常になる現象を改修しました。
    8. [寸法]−[記号]−[データム]コマンド
      基準レイヤと異なる縮尺のレイヤにデータムを記入すると、データム記号(線に接する△の形状)の大きさが異常になる現象を、改修しました。
    9. [寸法]−[伸縮]コマンド
      角度を変更した寸法値のある面取り寸法を伸縮しても、寸法値は角度を保持したまま移動するように改修しました。
    10. [寸法]−[公差]コマンド
      累進寸法値に対して公差を設定すると寸法線に重なる現象を、改修しました。
    11. [文字]−[定型]コマンド
     
[*置換]置換で累進寸法を置換した際、位置補正されない問題を改修しました。
[*置換]で手動寸法を置換するとおかしくなる問題を改修しました。
引出し時に複数行の文字列を配置した場合に、全て寸法文字の属性になるように改修しました。
[%F%]キーワードを配置する際、[設定1]〜[設定5]を切り替えても[ファイル名入力は拡張子を付けない]設定が切り替わらない問題を改修しました。
    12. [文字]−[連番記入]コマンド
      連番記入される文字のスタイルが、選択されているスタイルにならない事がある問題を改修しました。
    13. [文字]−[修正]−[連続]コマンド
      ”φ”、公差等が付加されている寸法値を選択すると、”φ”、寸法値、公差がばらばらに認識される問題を改修しました。
    14. [部品]−[機械要素]コマンド
     
初期設定が行われていない状態(新規インストール時など)で部品の配置を行った際、ダイアログ内の確認図では細線で描画されている部分が、実際には外形線として描画されてしまう問題を改修しました。
(穴パターン)バージョンアップを行った際に、データが欠落してしまう事がありました。欠落した場合、新規にデータを作成するように改修しました。
    15. [部品]−[形状の部品化]コマンド
      指定した要素が、グループ化されていて1グループになっている場合でも、形状の部品化が行えるように改修しました。
    16. [設定]−[属性]コマンド
     
(線種)線種属性を変更(補助線属性と他の属性)しても、変更されない現象を改修しました。
キャンセルすると、カレントスタイルと表示属性が違う状態になる現象を改修しました。
    17. [設定]−[スタイル]コマンド
      FXやJXペンスタイルを利用している場合に表示される[図面スタイルのインポート]ボタンが、スタイルダイアログをリサイズすると異常な位置に移動する現象を改修しました。
    18. [設定]−[レイヤ状態設定]コマンド
      基準レイヤと異縮尺のレイヤにある累進寸法値が、レイヤを操作(作成、状態変更、他レイヤ削除)した時に移動してしまう現象を改修しました。
    19. [ツール]−[プロコマンド]コマンド
      面取り線の線幅を基準要素の線幅とする設定としても、基準要素の線幅が反映されない事がある問題を改修しました。
    20. FX図面読込み/保存
      FX図面を読込み(レイヤセット利用しない)、編集後にFX図面として保存しても、FXのレイヤグループ制限(256レイヤグループ)を超えないように改修しました。
    21. レイヤ操作
     
[ユーザプロパティ設定]の[全般2]【用紙レイヤセットのリスト表示から複数所属レイヤを除く】が設定されていた場合、[寸法線][文字]にも所属するレイヤも表示されていなかったため正常にレイヤが表示されていなかった現象を改修しました。
寸法コマンド実行中に別レイヤセットに変更した場合、そのレイヤセット内の寸法レイヤに変更されなかった現象を改修しました。
(状態切替パネル)すべてのレイヤが休眠状態の設定を登録(全休眠)した場合、全休眠への状態変更、全休眠からの状態変更が正常に動作するように改修しました。
    22. [座標入力]機能
     
座標入力時に現在位置を表示する点が消えない場合がありましたが、座標入力終了時にすべて消去するように改修しました。
ステップ入力を利用中に、位置移動のない状態から「Enter」入力された場合、[確定]動作を行うように改修しました。
    23. 操作パネル
      操作パネルのドッキング位置、サイズを記憶するようにしました。
    24. コンソールパネル
      コンソールパネルのオートハイド状態を記憶するようにしました。
    25. コマンドパネル
      コマンド定義中、タブコマンドリストにコマンドをドロップしようとすると、思い通りの位置に挿入できない現象を改修しました。
    26. FXペンスタイルの利用
      FX図面を[FXペンスタイルの利用]状態で読み込んだ時、寸法線スタイルに破線/一点鎖線などが定義されてしまう現象を改修しました。
    27. キャンセル入力
      [アクティブ図面切替モード]を【CADSUPER】タイプで利用している場合、コマンド実行中に[ESC]キー入力を行うと、アクティブ図面が最上面に移動する現象を改修しました。
    28. ウインドウサイズ
      操作パネルをオートハイド状態で利用中、1枚目の図面を開く場合に「ファイルダイアログ」から開く場合と「エクスプローラ」から開く場合で、ウインドウサイズが異なる現象を改修しました。
 
  FXUユーティリティ関連
    機能強化項目
    1. 出力ユーティリティ
     
出力ユーティリティーからの連続印刷を行う場合、作図した図面サイズに合わせて自動的に印刷用紙サイズを切替できるようになります。
PDF出力の場合、用紙サイズの違う複数の図面を1ファイルに出力するようにしました。
(※以前は用紙サイズが違うと、別ファイルになっていました)
FX図面も出力ファイルとして、選択できるようにしました。
 
    2. 設定情報ユーティリティ
     
Administrator権限が無い状態でも、バックアップ/リストアできるようにしました。
※対象ファイルが一部制限されます。
AllUsers(デフォルト情報を保持)に対してリストアできるようにしました。
※ツールバー配置位置等のレジストリ情報は対象外です。
UNCパスへ直接バックアップ/リストアできるようにしました。
機械要素・プロコマンド・(設定情報を持つ)文字コマンドの利用情報を、バックアップ/リストアできるようにしました。
FXの機械要素・プロコマンド・文字アプリの利用情報を、FXUに移行できるようにしました。
JXからも環境移行できるようにしました。
※対象は、ベクトルフォント、プロッタプリンタ設定のみです。
 
    3. FXUコンバータ
     
DWG/DXFの変換で、レイヤが持つ色・線幅・線種の情報を双方向に変換できるよう対応しました。
変換の機能は、パラメータ設定で切り替えることができます。
DWG/DXFへの出力で、要素のレイヤの属性(色・線幅・線種)と一致する要素の場合、ByLayer属性で出力する機能を追加しました。
同様に、集合要素の構成する子要素の属性をINSERT要素の属性とし、子要素の属性をByBlockで出力する機能を追加しました。
出力の有無は、パラメータファイルのモード設定で切り替えることができます。
パラメータファイルの運用を、システムの既定のローカルフォルダで管理するよう変更しました。
任意のフォルダにあるこれまでのパラメータファイルは、パラメータ設定のインポート機能でローカルフォルダにコピーしてお使いいただけます。
パラメータファイルの操作は、基本的にファイル名のみで操作できるようインターフェースが変更されています。
※任意のフォルダでこれまで運用していた場合は、プログラムの起動時に通知メッセージが表示されることがあります。
 
    4. ビジュアルパラメータ
     
インターフェースを改良し、図面属性の割り当てを簡単でわかりやすく操作できるよう、操作体系を改善しました。
プレビューしているAutoCADの要素をクリックし、要素の情報を見ながらパラメータの割り当てができる機能を追加しました。
 
    機能改修項目
    1. FXUコンバータ
     
DXF・DWG変換(FXII->DXF・DWG)
異常な寸法情報のある図面を変換した場合に、RuntimeErrorが発生しない様に改修しました。
ハッチング要素として正しい情報に変換されない場合があったのを改修しました。
寸法記号と寸法値が重なる現象を改修しました。
AutoCADとFXIIでは、文字情報の表現方法が異なるので完全一致は出来ませんが、近い形状に出力するように改善しました。
レイヤ名称の処理部分に問題があったのを改修しました。
DXF・DWG変換(DXF・DWG->FXII)
バルーンや引出し線矢印の向きが反転する現象を改修しました。
文字拡縮比率を設定しても半値押されない現象を改修しました。
MC変換
寸法記号が欠落する問題で、寸法文字の扱いに問題があった部分を改修しました。