CADSUPER FXU Ver.3.00
   
FXU本体関連−機能強化項目
1. カスタム機能の提供
  FXUをカスタマイズする機能について、 .NET Framework で利用できるインターフェースを提供いたします。
2. コマンドの追加
 
[表示]−[レイヤ]−[全レイヤ書込み化]コマンドを搭載しました。
[作図]−[点]−[端点]コマンドを搭載しました。※標準メニューには搭載していませんので、コマンド定義で割り付けてご利用ください。
[編集]−[要素結合]コマンドを搭載しました。
[編集]−[移動]−[指定要素レイヤ間]コマンドを搭載しました。
[文字]−[一括移動・複写]コマンドを搭載しました(FXの文字アプリ−文字-大量移動・複写コマンドに相当)。
[寸法]−[記号]−[データム]コマンドを搭載し、データム記号の作図を行えるようにしました。
3. [レイヤ]関連コマンドの追加
 
コマンド定義 [表示]カテゴリに [表示モード切替]機能を追加しました(FXに存在)。
レイヤで指定した線種、線幅で作図を行う機能を選択できるようにしました。※当機能利用の場合、スタイルは無効となります。
既存要素をレイヤ設定で定義した線種、線幅、色に変更できる機能を搭載しました。[ツール]-[レイヤ内属性化]コマンド
既存の要素をレイヤの設定している色毎に振り分ける機能を搭載しました。[ツール]-[色別レイヤ分け]コマンド
4. [旧CADSUPERスタイル]インポート機能
  FXペンスタイル/JXペンスタイルを、FXU上のスタイルとしてインポートできる機能を搭載しました。インポート後は、FXU図面をインポートスタイルで利用することが出来ます。
FXU本体関連−機能改善項目
1. [ファイル]-[システムローカル設定]の改善
  [プロッター設定] プロッタ設定名としてユーザ任意名称を設定できるようにしました。
2. [作図]-[簡単ハッチング]コマンドの改善
  閉ループ認識後の[Y]入力で次のループ認識に入った場合も、「確定」入力でハッチングを作図するようにしました。
3. [編集]-[補正]-[自動]コマンドの改善
  線分化、円弧化、円弧分解で、楕円・曲線とポリラインとの処理を個別にするかどうかの設定を追加しました。
4. [寸法]-[記号]-[仕上げ]コマンドの改善
  部品の線分上に配置できるようになりました。
5. [寸法]-[バルーン]-[配置]コマンドの改善
  バルーン配置時、直前に入力した値を覚える、クリアする設定を追加しました。
6. [寸法]-[伸縮]コマンドの改善
  補助線を伸縮する場合、クリックした位置から設定-要素の寸法設定の引上げ長の位置で引出されるようにしました。
7. [設定]-[部品]-[機械要素]コマンドの改善
  ユーティリティ内に「メニュー一覧表示」の項目を設けました。旧メニュー形式で表示が行えます。
8. [設定]-[レイヤ設定]機能の改善
 
レイヤ設定で、[書込][参照][表示]/[休眠]と 出力[する]/[しない]を連動できる機能を搭載しました。
レイヤに 線種、線幅(、色)を設定できる機能を搭載しました。
9. [設定]-[ユーザプロパティ設定]の改善
 
[全般1]ページ:ユーザプロパティの設定でコマンドを起動する設定を追加しました。
[投影]ページ:投影図・断面図取得時の位数2(次数1)の曲線を、線分の集合要素として登録できる設定を追加しました。
[投影]ページ:断面のハッチング形状をFX2のハッチング要素として登録できる設定を追加しました。
[投影]ページ:投影形状を取得する際のカーブ近似精度としてシステム値を使用できる設定を追加しました。
10. [ツール]-[属性置換]コマンドの改善
  前回利用した設定状態で起動するようにしました。
11. [ツール]-[プロコマンド]-[円座標]コマンドの改善
  シンボルとしてあらかじめ用意した原点マークを表示できるようになりました。
12. [ツール]-[一括変換]コマンドの設定
  アドオン機能となっていたSX/JX/FXからの[一括変換]機能を、FXUのコマンドとして持つようになりました。利用する場合は、「コマンド定義」の各ページ内の「ツール」カテゴリから割り付けて利用してください。
13. [操作パネル]-[オートハイド機能]の改善
 
マウスがFXU外に出た場合もパネルオープン状態を維持するようにしました。
ハイドバーにハイドパネルの名称をすべて表示できるようにしました。
ハイドバーをマウスクリックで開閉できるようにしました。
14. [コンソールパネル]の改善
 
オートコンプリート機能を抑制しました。(データ入力エリア)
入力値を履歴表示するようにしました。
コンソールパネル上で利用されていたモードをコマンドモードバーで利用できるようにしました。
フローティング表示位置を固定位置にできるようにしました。
フローティング表示位置をFXU終了後も位置状態を保持するようにしました。
フローティング状態で常時表示できるようにしました。
文字入力フィールドのある場合のみフローティング表示サイズを別保持するようにしました。
ドッキング状態のコンソールパネルでは文字入力が行いにくいので、一時的にフローティング状態になる機能を搭載しました。
15. [図面ウインドウ]の改善
 
ウインドウタイトル上にマウスを移動すると、ファイル名を表示するようにしました。
図面オープン時、最大化状態で開く/開かない設定を行えるようにしました。
16. 表示速度の改善
 
文字の表示で遅延が発生する場合があるのを解消しました。
ズーム、パンニングの表示更新を見直し、マウス移動に追従するようにしました。
XPにおいて破線表示が遅い場合があるので、軽減できる機能を搭載しました。
17. [ファイルダイアログ]の改善
  ファイルダイアログを利用する場合に、特定のフォルダをデフォルトとして開く設定が出来るようにしました。
18. ファイル読込み機能の改善
 
図面データ読込み時の属性チェックを強化し、不正データや異常データに対処する機能を強化しました。
S-100Mデータで、文字の高さが負値の場合、正値に変換して読み込むようにしました。
19. [レイヤパネル/レイヤコンボ]機能の改善
  用紙+その他のレイヤセットに存在するレイヤは「用紙レイヤセット」に表示しない機能を設置しました。
20. コンテキストメニューの改善
  コンテキストメニューの表示サイズを調整しました。
21. 寸法コマンド起動時のスタイル改善
  寸法線作図時も実線のみのスタイルに抑制する設定を搭載しました。
22. [寸法値]の改善
  寸法公差の扱い方を変更し、自由なサイズ色での表現が出来るようにしました。
23. 線種名称作成用の削除文字に特定文字を追加
  線種名として不適当な全角数字を、削除対象文字として追加しました。
24. 出力名称の改善
  プリンタ/プロッタ出力名を「ファイル名」、「CADSUPER FX2」をコントロールできるようにしました。
FXU本体関連−機能改修項目
1. [ファイル]-[開く]コマンドの改修(SX/JX読込み)
  変換パラメータ設定が正常に反映されるように修正しました。
2. [ファイル]-[保存]コマンドの改修(FXD出力)
  レイヤ情報の状態、順番が入れ替わった場合の不具合を修正しました。
3. [編集]-[トリム]-[面取り]コマンドの改修
  機能実行時、利用されているデータのみコンソールパネル上の表示を「○:確定表示」になるようにしました。
4. [編集]-[移動/複写]コマンドの改修
  文字矩形と実際描画される文字のサイズが変わらないようにしました。
5. [編集]-[複写]コマンドの改修(図面間複写)
  不要なレイヤが新たに作成されないようにチェックを追加しました。
6. [編集]-[変形]コマンドの改修
  変形時の入力値が正常にロック出来るように修正しました。
7. [編集]-[補正]-[自動]コマンドの改修
  自動補正で楕円・曲線とポリラインを別々に処理できるようにしました。
8. [文字]-[記入]、[定型]コマンドの改修
  文字の仮表示矩形と実際に作図した文字の大きさが変わらないようにしました。
9. [文字]-[定型]コマンドの改修
  引出しを行う際に、2行目以降の下線が引出し線の属性と異なってしまう問題を修正しました。
10. [寸法]-[長さ]-[クイック]コマンドの改修
  記入した寸法を「自動」寸法として登録するように改修しました。
11. [寸法]-[長さ]-[累進]コマンドの改修
  既存累進寸法への寸法追加で、寸法線情報が逆転してしまう現象が発生していました。これによる無限ループが起こらないように対処しました。
12. [寸法]-[引出し]-[コメント]コマンドの改修
 
コメント入力の処理で、不正な状態にならないようにしました。
コメント入力後、自動的にFEPをOFFにするようにしました。
13. [寸法]-[伸縮]コマンドの改修
  同心円上への伸縮が出来るように改修しました。
14. [寸法]-[分割・統合]コマンドの改修
  既存角度寸法追加チェックを修正し、外側に正常に追加できるようにしました。
15. [寸法]-[伸縮]/[分割・統合]コマンドの改修
  要素未選択の状態で、レイヤを切替えることが出来るようにしました。
16. [寸法]-[一括変更]コマンドの修正
  連続した寸法線の公差が入れ替わる現象を修正しました。
17. [部品]-[パーツボックス]コマンドの改修
  部品フォルダに含まれている子フォルダ名の最後が"表"であった際に、そのフォルダ内の部品が表示されない問題を修正しました。
18. [設定]-[ユーザプロパティ設定]コマンドの改修
 
印刷できないページがあったのを修正しました。
新たにユーザプロパティを登録する場合に、ツールバーなどの配置情報も、元プロパティの情報からコピーするようにしました。
19. [設定]-[コマンド定義]コマンドの改修
  「3D図面展開オプション」、「プレス金型アプリ」が定義リストに表示されるように修正しました。
20. [ツール]-[プロコマンド]-[等分線]コマンドの改修
  補助線を基準線とした場合、図面枠レイヤに等分線が描画されるのを修正しました。
21. [ツール]-[プロコマンド]-[補助線削除]コマンドの改修
  補助線を基準線とした場合、図面枠レイヤに等分線が描画されるのを修正しました。
22. [ツール]-[プロコマンド]-[引き出し]コマンドの改修
  レイヤに縮尺がある場合、正常な位置に配置できなかった現象を修正しました。
23. [参照]コマンドの改修
  計測−距離の第1要素指定で、カレントと同縮尺レイヤ内の要素に限定しました。
24. [基準位置取得]機能の改修
  コンソールパネルをオートハイドで利用しているときに、位置指定「/」「*」「=」を正常動作するようにしました。
25. [コンテキストメニュー]選択の改修
 
不用意な情報による例外エラーが発生しないようにしました。
ショートカットキーが表示されているメニューがキー入力で起動できるようにしました。
26. アイコンの入れ替え
  [寸法]-[移動]と[寸法]-[伸縮]の画像が逆だったのを差し替えました。
27. バックアップファイルの作成機能の改修
  新規図面を保存した時に、サイズ0のバックアップが作成されてしまう現象を修正しました。
28. OLE2リンク情報の改修
  ハイパーリンクされたFXU図面を開くと、ファイル名などが化ける現象を修正しました。
FXU周辺機能関連−機能改善項目
1. [CADSUPER シェル機能]の改善
 
FX/FXUデータ上にマウスを乗せた時、「縮尺」「用紙サイズ」の情報を表示できるようにしました。
エクスプローラ/ファイルダイアログで図面属性「縮尺」「用紙サイズ」を詳細表示の項目として選択できるようにしました。
2. [FXUコンバータ]の改善
 
AutoCAD 2008のデータに対応しました。
DWG/DXF変換-属性重視での寸法付属文字の変換率を向上しました。
データム記号の変換に対応しました。
変換時に利用する機能をウイザード化し、利用しやすくしました。
3. 設定情報ユーティリティの改善
  個人環境を初期化する機能を追加しました。
FXU周辺機能関連−機能改修項目
1. FXUコンバータの改修
 
二重起動を抑制しました。
一部のファイル名がFXUコンバータで正常に利用できないものだったのを、正常に利用できるように対処しました。
Nurbs曲線の変換を改良しました。
引出し線(LEADER)変換時の矢印線端の処理をAutoCADに近づけました。
2. 設定情報ユーティリティの改修
  環境ファイルのバックアップで、SX/JX変換パラメータがバックアップされなかったのを修正しました。