CADSUPER FXU Ver.1.31
   
機能強化項目
1. [ファイル]-[名前をつけて保存]コマンド
  他形式(DXF/DWG/MCなど)に対して、上書き保存できるようにしました。
2. [線]-[平行線]コマンド
  始終点指定を座標で行ったとき、作成する平行線に対しての垂線の足座標になるようにしました。
3. [トリム]-[基準指定]コマンド
  トリムする要素に交点が取れない要素を指定しても、基準要素指定に戻らないようにしました。
4. [複写]-[平行]コマンド
  複写距離と複写回数を同時に利用できるようにしました。
5. [複写]-[行列]コマンド
  複写位置を指定した時点で、複写距離を入力エリアに表示するようにしました。
6. [移動]/[複写]-[レイヤ間]コマンド
  基準点を指定して異縮尺レイヤに移動(複写)できるようにしました。
7. [編集]-[認識編集]コマンド
  認識編集コマンドでも確認表示を利用できるようにしました。

8.

[編集]-[補正]-[近傍短点の接続]/[分断要素の統合]/[中間点による曲線の統合]コマンド
  レイヤを切り替えた場合にコマンドの始めに戻るようにしました。
9. [寸法]-[長さ]-[円弧長]コマンド
  180度を超える円弧に対して、確認表示を行わないようにしました。
10. [寸法]-[半径]-[折れ線]コマンド
  円弧の範囲外の位置で寸法を作図しないようにしました。
11. [設定]-[ユーザプロパティ設定]コマンド
 
作図中にユーザプロパティ設定でマウスカーソルタイプを変更したとき、即時反映するようにしました。
よく利用するコマンドモードの初期値を設定できるようにしました。
12. [投影図]コマンド
  モデルプレビューで軸線の表示をONにすると、投影図に軸線を作図するようにしました。
13. [認識(グループ認識設定)]コマンド
  認識マスクが利用できない場合に、認識コマンドのアイコンをグレイアウトするようにしました。
14. データ入力ダイアログ
  計測結果として記憶されている計測値を入力ダイアログのコンテキストメニューに表示するようにしました。
15. 位置入力機能
  ポイントモードが「フリー」「要素」の場合、位置入力は機能しないようにしました。
16. 初期ウィンドウサイズ
  FXU起動初期サイズを画面一杯にするようにしました。
17. 入力促進プロンプト表示
  確認メッセージの表現を統一しました。
機能改修項目
1. [ファイル]-[開く]コマンド修正
  ファイルダイアログのツリー表示で「図面フォルダ」の下に「図面テンプレート」を作成しました。ここで設定しているテンプレートフォルダを選択できるようにしました。
2. [ファイル]-[プリンタ出力]コマンド修正
  大サイズ図面の出力位置補正を修正しました。
3. [線]-[平行線]コマンド修正
  「始終あり」で平行距離を入力した場合も正常なラバーが出るように修正しました。
4. [編集]-[伸縮]コマンド修正
  楕円を伸縮する場合、伸縮位置として楕円に一番近い位置になるようにしました。
5. [トリム]-[自動]コマンド修正
  ハッチング要素でトリミングされないようにしました。
6. [編集]-[複写]-[平行]/[平回転]コマンド 図面間複写機能の修正
  図面間複写を行った場合に、線幅属性が追従しなかった現象を解消しました。
7. [編集]-[変形]コマンド修正
 
寸法値変更情報のチェックタイミングを見直しました。
データ入力ダイアログのロックが解除される不具合を改修しました。

8.

[認識編集]-[移動]-[平行]コマンド修正
  移動距離を入力できるように修正しました。
9. [認識編集]-[移動/複写]-[平回転]コマンド修正
  コマンドモードを修正しました。
10. [要素属性]-[要素変更]コマンド修正
  変更機能を見直しました。
11. [寸法]-[長さ]-[連段]コマンド修正
 
「作図方向」が「自動」の場合、描く位置指定時に、寸法値が0になったら、エラーメッセージを表示するようにしました。
「作図方向」が「自動」以外の場合、端点指定時に、寸法値が0になったら、エラーメッセージを表示し、次の操作に行かないようにしました。
「作図方向」が「自動」の場合、寸法線が表示されない不具合を改修しました。
「作図方向」が「水平」または「垂直」の場合、寸法線が重なる不具合を改修しました。
12. [設定]-[属性]コマンド修正
 
線種を入れ替えた場合の動作を正常にしました。
設定している「線幅」を削除すると、線幅に割り付けている色の設定がおかしくなる不具合を修正しました。
13. [設定]-[レイヤ状態設定]コマンド修正
 
縮尺入力エリアのコントロールを見直しました。
ダイアログの表示を見直しました。
14. [ツール]-[表]-[部品表]コマンド修正
  エクセルが入っていないマシンでExcel出力を選んでも出力できないようにしました。
15. ツールバーの配置位置
  ツールバーの配置情報を見直し、起動時に隙間が開かないようにしました。
16. 中間点による曲線の統合
  曲線の統合処理を見直しました。
17. ポリラインの補正対応
  DXF/DWGのポリライン形式の集合要素を線分化・円弧化・円弧分解の対象とするようにしました。
18. ファイルダイアログの修正
 
CSLINKのファイル名長さチェックを修正しました。
選択可能な拡張子を一部見直しました。
19. 図面テンプレート利用の修正
  縮尺の入った図面テンプレートを正常に利用できるようにしました。
20. 座標認識の修正
 
すばやい動作で要素選択した時でも、正常に端点を検出できるように修正しました。
座標認識で、拡大ウインドウを利用後に要素を選択した場合でも、正常な端点を検出できるように修正しました。
21. 要素認識の修正
  ナビゲーションOFFで、第1レイヤと異なる縮尺上の要素を2つ認識しようとした場合に、2つ目が正常に取れない現象を解消しました。
22. ループ検索の修正
 
任意要素からの自動サーチループ検索で中断出来るようにしました。
閉区域の判定を見直しました。
23. FX互換モード
  FX互換モードで利用している場合に、他形式(JX,SX,DXF,DWG)への出力を出来るようにしました。
24. 排他制御機能の改善
  FXデータについて排他制御コントロールを行うようにしました。
25. 排他制御ユーティリティの改善
  FXUの排他制御ツールでFXデータも排他コントロールできるようにしました。
26. ライセンス機能の修正
 
電源の休止と復旧において、IDBOX未接続状態が続くのを回避するようにしました。
サーバーサービス起動後に挿入されるIDBOXを検出するようにしました。
27. [線]−[線分]コマンドの改善
  基準レイヤ(レイヤリスト内の最初のレイヤ)とは異なる縮尺のレイヤ上で、線分を[自動(コマンドモード1)]で作図しようとすると、正常な位置に作図されない現象を解消しました。